The forum is in read only mode.

AVL 3.32

  • chavagne jean
  • Topic Author
  • Offline
  • New Member
  • New Member
10 years 11 months ago #7084 by chavagne jean
AVL 3.32 was created by chavagne jean
Now i am on ubuntu 12.04. I try to get AVL 3.32.
When in AVL/eispack Makefile, i change FC=gfortran ( like this )

FC = gfortran
FLG = -O
EISLIB = eispack.a
AR = ar r
RAN = ranlib

DP =

#- uncomment for double-precision option
DP = -r8

eispack.a: eispack.f
$(FC) -c $(FLG) $(DP) eispack.f
$(AR) $(EISLIB) eispack.o

/bin/rm *.o *.a

i have this :

(chavagne@chavagne-desktop:~/Avl/eispack$ gedit Makefile
chavagne@chavagne-desktop:~/Avl/eispack$ make
gfortran -c -O -r8 eispack.f
gfortran: erreur: unrecognized option ‘-r8’
make: *** [eispack.a] Erreur 1

What i have to do?
thanks a lot
10 years 11 months ago #7085 by Chris M
Replied by Chris M on topic Re: AVL 3.32
Hey friend,

I made a post in UbuntuForums about installing AVL in Ubuntu not to long ago.


Basically for this specific problem change DP = -r8 to DP = -dbl

thats what worked for me when I was using g77. It may be different for gfortran because its basically the double precision compiler flag. If the -dbl option doesn't work try -fdefault-double-8. I think thats gfortran's double precision flag. For further reference on gfortran flags visit this page: linux.die.net/man/1/gfortran

Or search the gfortran man pages.

Have fun
8 years 2 months ago - 8 years 2 months ago #8607 by vk
Replied by vk on topic Re: AVL 3.32
Hi chav & Eezyville

I ran into the same problem trying to compile avl 3.35 on my ubuntu 14.04 (trusty).

I made a post in UbuntuForums about installing AVL in Ubuntu not to long ago

I did read it thoroughly. However some of the compiler command (e.g. -dbl) are "outdated".
I tried to work around it without any luck. It compiles "successfully", but running AVL I get the output:
  Athena Vortex Lattice  Program      Version  3.35
  Copyright (C) 2002   Mark Drela, Harold Youngren

  This software comes with ABSOLUTELY NO WARRANTY,
    subject to the GNU General Public License.

  Caveat computor

Program received signal SIGFPE: Floating-point exception - erroneous arithmetic operation.

Backtrace for this error:
#0  0x7F122DA98777
#1  0x7F122DA98D7E
#2  0x7F122CF98D3F
#3  0x4046CA
#4  0x406898
#5  0x407BAA
#6  0x7F122CF83EC4
#7  0x402CC8
Floating point exception (core dumped)

Any tips, updates on that tutorial?

Correction: running AVL with an input file works! without an input I get the above mentioned error.
Last edit: 8 years 2 months ago by vk.
Moderators: catux
Time to create page: 0.162 seconds
Powered by Kunena Forum