The forum is in read only mode.

Hardware and Update

7 years 11 months ago #8721 by Mike
Hardware and Update was created by Mike
Two quick questions with long answers.

What hardware do you folks use to run these programs and what sized problems can be reasonably solved ? I7 vs XEON? One or two processors per board? ECC memory? How much memory per core or thread? HP? Dell? Lenovo?

Any benchmarks been run?

Any thoughts of updating to Ubuntu 16.04 LTS?

If you've installed CAELinux based on 12.04 and upgrade to 16.04 will CAELinux still work?

I'd like to upgrade to a newer computer, probably an off lease system from EBay, and any guidance will be greatly appreciated.
7 years 11 months ago - 7 years 11 months ago #8722 by J S
Replied by J S on topic Re: Hardware and Update
I ran quite a few traditional FEA cases in 2010 on Caelinux with a 2006 Dell Xeon quad core "5300" with 6GB ram, which was an upgrade from my 2002-ish Dell P4 2GB ram single core desktop that I started older versions of Caelinux on. I ran models that were 1m x 1m x 0.5m in size. The actual solver run time was short even on the older machines. All the work is setting up the models which is only human-speed.

If you get models from someone using Catia, they need to remove fillets that intersect. Catia creates three sided curved shells in the corner where three fillets run into each other and it doesn't translate through step formats to use in Caelinux.

Upgrading to 2016 xubuntu: I spent quite a bit of time which was mostly getting the correct steps to upgrade. Google "wiki.ubuntu.com releasenotes 14.04 LTS" and then the same for 16.04 and scroll down to the how to upgrade sections. There is some sort of user permission problem on the terminal program so you need to run the root terminal version (which you'd need anyway to upgrade). That got the basic OS working. However, a few things seem broken in Caelinux. A library is missing in code-saturne that I need to track down (libparmetis.so.3.1) to do my CFD problem I'm running this again, and user terminal still doesn't work. All the rest of the desktop software like libreoffice/gimp/etc are all updated to current. I haven't tried standard code-aster FEA yet. FreeCad is updated to 0.15. Salome-meca 2013.1 version seems to work fine.

My recommendation is if you have a modern-ish computer that you put a bare-bones Debian base OS on it with Virtualbox and then run CAELinux from the .iso on a virtual machine with not much else open. That will be the easiest. More Ram and higher power CPUs are always better but you can do quite a bit with an older machine. Then you close down the Caelinux package after done with your work.
Last edit: 7 years 11 months ago by J S.
Moderators: catux
Time to create page: 0.119 seconds
Powered by Kunena Forum